Regenerate Thumbnails

Plugin Description:

Regenerate Thumbnails allows you to regenerate all thumbnail sizes for one or more images that have been uploaded to your Media Library.

This is useful for situations such as:

  • A new thumbnail size has been added and you want past uploads to have a thumbnail in that size.
  • You’ve changed the dimensions of an existing thumbnail size, for example via Settings ? Media.
  • You’ve switched to a new WordPress theme that uses featured images of a different size.

Download:

Screenshots:

822 thoughts on “Regenerate Thumbnails

  1. hey facing this isuue There was an error regenerating this attachment. The error was: Unable to load the metadata for this attachment.

  2. Pingback: Sending Positive Vibes to Alex Viper007Bond Mills – WordPress Tavern

  3. Pingback: WPTavern: Sending Positive Vibes to Alex Viper007Bond Mills | wpRandy Ft Lauderdale WordPress and WooCommerce Expert

  4. Pingback: Alex Mills Ends His Battle With Leukemia – WordPress Tavern

  5. Pingback: WordPress Plugins zur Bildbearbeitung — WPImagePro

  6. Pingback: Sử lý vấn đề tạo ảnh thumbnails trên WordPress - BIBICA.NET

  7. Pingback: Sending Positive Vibes to Alex Viper007Bond Mills - PressSearch

  8. Hello
    I am trying to regenerate thumbs by your plug in the thumbs are png
    the problem that when generating the thumbs it gives them white background

  9. Thanks for this plugin – I use it so often and it’s been brilliant.
    I’m having an issue with errors, and I can’t work out why. A number of the images are skipped:
    “There was an error regenerating this attachment. The error was: There has been a critical error on your website.
    Learn more about debugging in WordPress.”
    This is not very helpful!

    When I look at the source images, they seem fine (not missing the original). Some of the sizes have already been generated, but a number haven’t, like the Woocommerce and Elegant themes ones.

    Could you comment or help?
    Thanks!

  10. “Warning: This plugin has not been tested with your current version of WordPress.” “Compatible up to: 5.4.2”. I have 5.5.1. So I should delete this plugin and use something else? Or it is actually compatible? Please clarify.

  11. Hey All, Just wanted to mention here as a lot of you seem to be coming to the commets section for the plugin and not reading the main blog.

    Alex lost his fight with Leukemia and has unfortunately passed away. Read more on his main blog https://alex.blog/

    You will unfortunately not get answers for this great plugin until it’s forked.

Leave a Reply to Anna Rita Cancel reply